It is currently Sun Aug 19, 2018 9:36 am


Disable Z depth

For every thing to do with shaders.
  • Author
  • Message

garionek

  • Posts: 5
  • Joined: Thu Sep 15, 2016 6:56 pm

Disable Z depth

PostThu Sep 15, 2016 7:05 pm

Advanced lighting is amazing! I'm working on an RTS game in DBP with AL and trying to do some fog of war. Normally I used a textured black plain object along with DISABLE OBJECT ZDEPTH. However, this function has no effect in Advanced Lighting. It just renders out normally instead in front of all other objects. Perhaps you can have some tips?

Thank you again for your awesome work Evolved
Attachments
gierka_day3_5.jpg
gierka_day3_5.jpg (204.6 KiB) Viewed 1692 times

garionek

  • Posts: 5
  • Joined: Thu Sep 15, 2016 6:56 pm

Re: Disable Z depth

PostSat Nov 19, 2016 7:35 pm

So if anyone is wondering, disable z depth doesn't work with alpha shader.

It does, however, work with other shaders, like FOG shader, object shaders or even lens flare shader. All work fine as fog of war in this example, you only have to disable post effect distortions to disable chromatic aberration in those shaders and voila.

Cheers!

Return to Shaders



cron