It is currently Sun Sep 22, 2019 7:45 am


Issue with exported vertex colors

Any thing to do with Tree It, post and read about it here.
  • Author
  • Message

klimak

  • Posts: 2
  • Joined: Wed Jun 12, 2019 3:17 pm

Issue with exported vertex colors

PostWed Jun 12, 2019 5:10 pm

Hi, I seem to have run into an issue with the vertex weights when exporting into the FBX format.

These are the vertex colors when viewed in TreeIt: https://i.imgur.com/W8D87I2.jpg

Everything looks right there. However, this is what they look like in a 3D application: https://i.imgur.com/cMfBNii.jpg

And this is what they look like in Unity: https://i.imgur.com/q7kdYYP.jpg

Maybe I'm missing something or overlooking a setting somewhere, but I'm having trouble shading these properly since the vertex color of the secondary branches is completely different from the main branches. Toggling the "combine" options in the export settings doesn't change anything as far as I can tell. Changing the "wind vertex color" setting on the mesh to "inherit" also had no effect.

It seems like it might have something to do with the fact that these trees use mesh branches, since I haven't run into the same issue with trees that only use "leaves" like "juniper.tre" from the tree library. Maybe the vertex colors being exported are from the original branch mesh file and they aren't being properly adjusted to fit into the tree, like in the main TreeIt 3D view? I can't tell if this has anything to do with the other vertex color problem from the thread back in November.

The tree in the screenshots is "oak.tre" from the tree library, but I checked and the same thing happens with "maple.tre" (included with the main TreeIt download) which also uses mesh branches.

In any event, thanks a lot for making this program available, it's excellent and very much appreciated.
User avatar

EVOLVED

Site Admin

  • Posts: 32
  • Joined: Wed Mar 05, 2014 7:52 am

Re: Issue with exported vertex colors

PostWed Jun 12, 2019 10:07 pm

An update has just been made that will hopefully fix this. Not sure why this was occurring so I have redone the vertex color export code and seems to be working properly.

As this was an issue on the dbo export as well and has now been fixed for this format, I just need confirmation that its fixed for fbx format also.

klimak

  • Posts: 2
  • Joined: Wed Jun 12, 2019 3:17 pm

Re: Issue with exported vertex colors

PostWed Jun 12, 2019 10:48 pm

Hey again. It seems like that did it, the colors look good now: https://i.imgur.com/U9pHrwf.jpg

Thanks for the quick response, and thanks again for the great software.

Return to Tree It



cron